voyent
AHS configured as server, but getting some wierd apache access  XML
Forum Index -> Async HTTP Server
Author Message
FlyingElvi

Joined: 15/Dec/2006 00:00:00
Messages: 80
Offline


Hi !

I have AHS configured as a server in JBoss 4.2.3 with Apache 2.2 in front.

My application run fines, but when I look in the Apache access log i see these entry:

Code:
10.10.11.107 - - [31/Oct/2008:11:38:30 -0400] "POST /async-http-server/block/receive-updated-views HTTP/1.1" 404 243


They are there often, and they are getting the 404 treatment.

Can anyone explain what they mean and what should I do ?

Thank you

Max
craig

Joined: 28/Nov/2006 00:00:00
Messages: 164
Offline


Hi I am getting the same issue but with using tomcat

Did you find the answer to this?

Thanks

Craig

FlyingElvi

Joined: 15/Dec/2006 00:00:00
Messages: 80
Offline


No i didn't find any answer and it seems to be breaking the server push of my application.

If I redirect them, it work on a single node environement, but nor in a clusted environnement.

Any idea, anyone ?

Thanks

Max
FlyingElvi

Joined: 15/Dec/2006 00:00:00
Messages: 80
Offline


well I added the stickySession parameter to the ProxyPass for the AHS server and now it seems ok.

And also I'm redirecting all the /async-http-server to the AHS URL

Max
jack.van.ooststroom


Joined: 26/Oct/2004 00:00:00
Messages: 223
Offline


Hello,

The ICEfaces Core is doing some auto-detection to ease the configuration that needs to be done by the user. It detects that AHS is used and automatically sets the blockingRequestHandlerContext to "async-http-server". Though this is mandatory when AHS is running in servlet-mode, it is not necessary when it's running in server-mode. Your solution to redirect the /async-http-server to AHS is correct, but sticky session is not necessary when dealing with the blocking requests for AHS.

Regards,

Jack van Ooststroom
Senior Developer
ICEsoft Technologies, Inc.
[Email]
 
Forum Index -> Async HTTP Server
Go to:   
Powered by JForum 2.1.7ice © JForum Team