voyent
IceFaces stopped working after GlassFish update  XML
Forum Index -> Woodstock to ICEfaces Migration
Author Message
rogier.de.groot

Joined: 21/Jan/2009 00:00:00
Messages: 3
Offline


Hello everyone,

I have been porting a Woodstock web application to ICEFaces, running on GlassFish v3 prelude & using NetBeans 6.5. The porting itself was going great, but since a recent update to the glassfish-jsf module all pages now using IceFaces keep crashing with an UnsupportedOperationException.
I can't undo the update unfortunately. The Woodstock-only pages still work fine. Does anyone know how to fix this?
frank.ye

Joined: 26/Oct/2004 00:00:00
Messages: 709
Offline


Services --> GlassFish V3 --> View Update Center --> Open Image --> GlassFish v3 Preclude --> Installed Components

Could you look at the View Update Center and tell me the Installed Components
(GlassFish JSF )'s Version?

thanks,
[Email]
rogier.de.groot

Joined: 21/Jan/2009 00:00:00
Messages: 3
Offline


It's glassfish-jsf version 2.0.0-8.
frank.ye

Joined: 26/Oct/2004 00:00:00
Messages: 709
Offline


jsf 1.2 is supported. jsf 2.0 will be supported in the future release.
Could you use updatetool to down-grade the Glassfish jsf? The Installed Components could be removed from update Tool.
[Email]
rogier.de.groot

Joined: 21/Jan/2009 00:00:00
Messages: 3
Offline


No, can't get rid of it, not without reinstalling the whole app server. Would icefaces 1.8.0 DR2 work?
frank.ye

Joined: 26/Oct/2004 00:00:00
Messages: 709
Offline


no, 1.8.0 DR2 will not support JSF 2.0.

update tool using image package so it should be able to remove and install any available packages.



[Email]
 
Forum Index -> Woodstock to ICEfaces Migration
Go to:   
Powered by JForum 2.1.7ice © JForum Team