voyent
Glassfish V3 and Icefaces 2 Startup problem  XML
Forum Index -> Contributor's Corner
Author Message
Mirackle

Joined: 27/Oct/2008 00:00:00
Messages: 10
Offline


I`m trying to deploy simple application to Glassfish v3.
I`m using Equinox for OSGI functions.

Then i`m trying to deploy app, server send me mony error.
All of them is like this one:

[#|2010-01-21T12:41:32.023+0300|WARNING|glassfishv3.0|javax.enterprise.system.container.web.org.glassfish.web.loader|_ThreadID=35;_ThreadName={felix.fileinstall.poll=5000, felix.fileinstall.bundles.new.start=true, service.pid=org.apache.felix.fileinstall.cebf1f73-a8e1-4984-9c2d-2a313d545311, felix.fileinstall.dir=/usr/local/glassfish/glassfish/domains/domain1/autodeploy/bundles/, felix.fileinstall.filename=org.apache.felix.fileinstall-autodeploy-bundles.cfg, service.factorypid=org.apache.felix.fileinstall, felix.fileinstall.debug=1};|WEB9052: Unable to load class com.icesoft.faces.component.ext.renderkit.MenuRenderer, reason: java.lang.NoClassDefFoundError: javax/faces/render/Renderer|#]

ken.fyten

Joined: 26/Oct/2004 00:00:00
Messages: 1334
Offline


Hi,

ICEfaces 2.0 Alpha 2 is out. Recommend you try that, it should deploy to Glassfish 3 by default.

Regards,
Ken

Ken Fyten
VP Product Development
ICEsoft Technologies, Inc.
Mirackle

Joined: 27/Oct/2008 00:00:00
Messages: 10
Offline


It will be good thing to place Icefaces 2.0 Alpha and Beta Releases to pubic maven storage.

Thank you.
Mirackle

Joined: 27/Oct/2008 00:00:00
Messages: 10
Offline


About pom`s in Alpha2.

They have mistakes.

icefaces-compat have dependency to icefaces-comps 2.0-A2.
But this artifact is not exists.

May-be it need to change to icefaces-comps-compat ?

And icefaces.pom have dependency to javax.servlet.jstl 3.0

I can`t find this artifact on public maven repository.

judy.guglielmin

Joined: 20/Feb/2007 00:00:00
Messages: 1396
Offline


the dependency in icefaces-compat is icefaces-2.0.A2

icefaces-2.0.A2 does not have dependency to servlet 3.0 so just remove that.
Mirackle

Joined: 27/Oct/2008 00:00:00
Messages: 10
Offline


judy.guglielmin wrote:
the dependency in icefaces-compat is icefaces-2.0.A2

icefaces-2.0.A2 does not have dependency to servlet 3.0 so just remove that.  


Please check icefaces-compat.pom from bin package from your web site.

Code:
  <url>http://www.icefaces.org</url>
   <description>ICEfaces is an Ajax extension for JavaServer Faces-2.0. Compat version for 1.8.2</description>
   <dependencies>
     <dependency>
       <groupId>org.icefaces</groupId>
       <artifactId>icefaces-comps</artifactId>
       <version>${version}</version>
     </dependency>
 
     <dependency>
       <groupId>commons-beanutils</groupId>
       <artifactId>commons-beanutils</artifactId>
       <version>1.8.0</version>
     </dependency>
 
 ......
judy.guglielmin

Joined: 20/Feb/2007 00:00:00
Messages: 1396
Offline


Yes, we realize that and they are now corrected to the above statements. Thanks for letting us know.
Mirackle

Joined: 27/Oct/2008 00:00:00
Messages: 10
Offline


Can you also tell me how i can get trunk sources from svn?
judy.guglielmin

Joined: 20/Feb/2007 00:00:00
Messages: 1396
Offline


Check this link

However, it won't be updated right away (there is a delay) so changes to the poms might not be there until later today.
Mirackle

Joined: 27/Oct/2008 00:00:00
Messages: 10
Offline


I have tryed this url and it not works.

Code:
 $ svn co http://anonsvn.icefaces.org/repo/icefaces/scratchpads/glimmer/
 .......
 ......
 
 
 svn: warning: Error handling externals definition for 'glimmer/core/src/main/javascript/lib':
 svn: warning: OPTIONS of 'http://server.ice:8888/svn/ossrepo/projects/bridge-support/src/main/javascript': Could not resolve hostname `server.ice': Host not found (http://server.ice:8888)
 svn: warning: Error handling externals definition for 'glimmer/compat/core/src/main/javascript/lib':
 svn: warning: OPTIONS of 'http://server.ice:8888/svn/ossrepo/projects/bridge-support/src/main/javascript': Could not resolve hostname `server.ice': Host not found (http://server.ice:8888)
 Checked out revision 20367.
 


ken.fyten

Joined: 26/Oct/2004 00:00:00
Messages: 1334
Offline


Hi,

We started to use the svn "externals" feature with this release, and it is causing some problems with our public rep, as you've seen.

We're investigating a solution, but in the meantime I'd recommend you download the icefaces-2.0.0-alpha2-src.zip bundle if you require source code.

Regards,
Ken

Ken Fyten
VP Product Development
ICEsoft Technologies, Inc.
ted.goddard

Joined: 26/Oct/2004 00:00:00
Messages: 874
Offline


Please try checking out the repository again; the svn:externals has now been made relative.
[Email]
 
Forum Index -> Contributor's Corner
Go to:   
Powered by JForum 2.1.7ice © JForum Team