voyent
Javascript issues on Icefaces preventing further actions  XML
Forum Index -> Portals & Portlets
Author Message
bsindhuja

Joined: 15/Jan/2010 00:00:00
Messages: 2
Offline


Hi,

We are developing portlets using Liferay 5.2.3 and Icefaces 1.8.2. We had used most of the Icefaces custom components. We are facing a strange issue at times that any action or navigation is not happening on button or link click. The firefox error console says 'setFocus()' is not defined and other javascript functions internally used by icefaces are not defined.

Our web.xml contains,

<context-param>
<param-name>com.icesoft.faces.compressResources</param-name>
<param-value>false</param-value>
</context-param>

Inspite of that entry set to false, we are facing this issue. Also this problem is not happening always. sometimes the application is working fine and sometimes not responding to user actions.

We are using the following jars,
backport-util-concurrent.jar
el-ri.jar
icefaces.jar
icefaces-comps.jar
icefaces-facelets.jar
jsf-api.jar
jsf-impl.jar

Please help us get this issue resolved. It is a bit urgent deliverable.

Thanks,
Sindhuja
malm

Joined: 29/Jan/2010 00:00:00
Messages: 5
Offline


grettings

I need to solve an issue with icefaces and javascript.
i've a popup component with a datatable, whose data is loaded from database.
the datatable's content draws a table with 10.000 rows and a range of 30-50 columns, and performance is very slow when it shows datatable in the popup...

in a web browser (IE, firefox, etc) it shows a message with options to stop or continue script, and a url of the script. in some cases it come from barebone.jsp (with some additional params)...

any ideas for this???

mads

Joined: 29/May/2008 00:00:00
Messages: 20
Offline


Did you solve your problem,i am having same issues
 
Forum Index -> Portals & Portlets
Go to:   
Powered by JForum 2.1.7ice © JForum Team