voyent
How do I configure ICEfaces 3.3 to work on Weblogic 10.3.6, to avoid "failed to append text into..."  XML
Forum Index -> General Help
Author Message
killerwhaletank

Joined: 17/Dec/2008 00:00:00
Messages: 7
Offline


I'm using Weblogic 10.3.6 as a server and JDeveloper 11.2.3 as an IDE. I have a JSF 2 application that is working fine so far using just the native JSF components, no other third-party components.

I tried to add ICEfaces to the application, but am encountering difficulties and I'm running out of ideas... nothing I've come across so far has helped. I keep getting this error as soon as I include the ICEfaces jars:

java.lang.RuntimeException: failed to append text[

] into #document
at org.icefaces.impl.context.DOMResponseWriter.appendToCursor(DOMResponseWriter.java:439)
at org.icefaces.impl.context.DOMResponseWriter.appendToCursor(DOMResponseWriter.java:415)
at org.icefaces.impl.context.DOMResponseWriter.writeText(DOMResponseWriter.java:352)
at com.sun.faces.facelets.compiler.LiteralTextInstruction.write(LiteralTextInstruction.java:76)
at com.sun.faces.facelets.compiler.UIInstructions.encodeBegin(UIInstructions.java:82)
at com.sun.faces.facelets.compiler.UILeaf.encodeAll(UILeaf.java:183)
at javax.faces.component.UIComponent.encodeAll(UIComponent.java:1782)
at com.sun.faces.application.view.FaceletViewHandlingStrategy.renderView(FaceletViewHandlingStrategy.java:439)
at com.sun.faces.application.view.MultiViewHandler.renderView(MultiViewHandler.java:124)
at com.sun.faces.lifecycle.RenderResponsePhase.execute(RenderResponsePhase.java:120)
at com.sun.faces.lifecycle.Phase.doPhase(Phase.java:101)
at com.sun.faces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:139)
at javax.faces.webapp.FacesServlet.service(FacesServlet.java:594)
... 39 more
Caused by: org.w3c.dom.DOMException: HIERARCHY_REQUEST_ERR: An attempt was made to insert a node where it is not permitted.
at com.sun.org.apache.xerces.internal.dom.ParentNode.internalInsertBefore(ParentNode.java:356)
at com.sun.org.apache.xerces.internal.dom.ParentNode.insertBefore(ParentNode.java:284)
at com.sun.org.apache.xerces.internal.dom.CoreDocumentImpl.insertBefore(CoreDocumentImpl.java:399)
at com.sun.org.apache.xerces.internal.dom.NodeImpl.appendChild(NodeImpl.java:235)
at org.icefaces.impl.context.DOMResponseWriter.appendToCursor(DOMResponseWriter.java:434)
... 51 more 


I tried downloading the latest ICEfaces 3 and followed several different tutorials and posts to try to get it to work, but no matter what I do, I keep getting the same error. So I thought maybe ICEfaces 3 doesn't like Weblogic 10.3 (it's JSF 2 but maybe not the right ServletContainer) so I went back and found an older version of ICEfaces 2 and I get the same problem.

I even went as far as to try using ICEfaces 1.8 and run it in compatibility mode as per one of the tutorials on this site, just to see if I could make it work, and I get the same thing.

I'm stuck at this point... to the point where I'm going to have to ditch ICEfaces completely and just try Oracle ADF. I didn't want to do that because we have other apps using ICEfaces and I wanted to keep it all the same, but I can't spend much more time on this without making progress.

I have another older ICEfaces app that was originally deployed on OAS, with ICEfaces 1.8, and JSF 1.2. It was converted to run on our new Weblogic server and is still using ICEfaces 1.8 and JSF 1.2 with no problem. However, this app is a new JSF app and I don't want to build something new based off of JSF 1.2 when I now have JSF 2 available.

Has anybody been able to make this work at all? I had a heck of a time getting ICEfaces 1.8 to work with JDeveloper and OAS, but I did finally get it to go... this can't be nearly as bad as that, can it??

Any help is appreciated... is there a tutorial or a post I've missed that might help me?
 
Forum Index -> General Help
Go to:   
Powered by JForum 2.1.7ice © JForum Team