voyent
IE 10 behaves weird when form validation fails  XML
Forum Index -> Components
Author Message
zeeshan.rb

Joined: 23/Jun/2012 00:17:20
Messages: 63
Offline


Hi, iam using icefaces ace 3.2. I have a form which has validtions, which fire properly in IE 9 and below, it also works in firefox n other browsers also, meaning the vaidation messages show up properly in form. But after i upgraded my IE to ver 10, whenever my validation fails , I see n xml for partial response outputed to browser with xml tags. and below is what i see in the browser.

<?xml version="1.0" encoding="UTF-8"?>
-<partial-response>-<changes>-<update id="javax.faces.ViewState">
<![CDATA[2869920248147583345:1319176984591285312]]>
</update>-<eval>
<![CDATA[bringFocus();//-258663230]]>
</eval></changes><extension aceCallbackParam="validationFailed">{"validationFailed":false}</extension></partial-response>

How can I fix this for IE10
[Thumb - Untitled.jpg]
 Filename Untitled.jpg [Disk] Download
 Description
 Filesize 72 Kbytes
 Downloaded:  347 time(s)

zeeshan.rb

Joined: 23/Jun/2012 00:17:20
Messages: 63
Offline


can anyone please help.
philip.breau


Joined: 08/May/2006 00:00:00
Messages: 2989
Offline


Is the partial response different in the other browsers?

.
zeeshan.rb

Joined: 23/Jun/2012 00:17:20
Messages: 63
Offline


Thanks for your response. Yes the partial response is different in IE10 and Firefox. I captured it from the Developer tools. Point to note is that there is no problem if i change browser mode in IE10 to "IE 10 Compatibility View" or Older versions of IE.

Code:
  ------IE10-------
 <?xml version="1.0" encoding="UTF-8"?>
 -<partial-response>
 -<changes>
 -<update id="javax.faces.ViewState">
 <![CDATA[3449796221107496921:9163176408364250875]]>
 </update>
 -<eval>
 <![CDATA[bringFocus();//-1901847438]]>
 </eval>
 </changes>
 <extension aceCallbackParam="validationFailed">{"validationFailed":false}
 </extension>
 </partial-response>
 
 -------firefox 26 --------
 <?xml version='1.0' encoding='UTF-8'?>
 <partial-response>
 <changes>
 <update id="form:cal_input"><![CDATA[<input aria-invalid="true" aria-required="true" class="ui-inputfield ui-widget ui-state-default ui-corner-all ui-state-required ui-state-error" id="form:cal_input" name="form:cal_input" readonly="readonly" role="textbox" size="7" type="text" />]]>
 </update>
 <update id="form:dateoftran_input"><![CDATA[<input aria-invalid="true" aria-required="true" class="ui-inputfield ui-widget ui-state-default ui-corner-all ui-state-required ui-state-error" id="form:dateoftran_input" name="form:dateoftran_input" readonly="readonly" role="textbox" size="10" type="text" />]]></update>
 <update id="form_fixviewstate"><![CDATA[<span id="form_fixviewstate"><script type="text/javascript">ice.fixViewState('form', '5418711552146948613:4541678015922354401');//5874795496377019995</script></span>]]></update>
 <update id="v5uawq38-retrieve-update_fixviewstate"><![CDATA[<span id="v5uawq38-retrieve-update_fixviewstate"><script type="text/javascript">ice.fixViewState('v5uawq38-retrieve-update', '5418711552146948613:4541678015922354401');//914868409796527783</script></span>]]></update>
 <update id="v5uawq38-single-submit_fixviewstate"><![CDATA[<span id="v5uawq38-single-submit_fixviewstate"><script type="text/javascript">ice.fixViewState('v5uawq38-single-submit', '5418711552146948613:4541678015922354401');//-7804241196402247469</script></span>]]></update>
 <update id="javax.faces.ViewState"><![CDATA[5418711552146948613:4541678015922354401]]></update>
 <eval><![CDATA[bringFocus();//-1874497658]]></eval>
 </changes>
 <extension aceCallbackParam="validationFailed">{"validationFailed":true}
 </extension>
 </partial-response>
 
philip.breau


Joined: 08/May/2006 00:00:00
Messages: 2989
Offline


Ok, if you'd like to attach a test case we can take a look thanks.

.
zeeshan.rb

Joined: 23/Jun/2012 00:17:20
Messages: 63
Offline


Can u tel me what u expect I a testcase. Do u want only the test steps, or u want me also to upload a sample project which you canuse to simulate
philip.breau


Joined: 08/May/2006 00:00:00
Messages: 2989
Offline


Yes, please attach a sample project to test.

Thanks

.
PeterReinecke


Joined: 12/Aug/2013 02:41:40
Messages: 29
Offline


Is there any more information about this problem?

I have the same problem with IceFaces 4.2.0 in all browsers.
 
Forum Index -> Components
Go to:   
Powered by JForum 2.1.7ice © JForum Team