voyent
Problems with javascript on the client side  XML
Forum Index -> General Help
Author Message
Maksim_A

Joined: 27/Feb/2018 02:01:24
Messages: 18
Offline


Hello. I have a button on my page that is responsible for calling the action performance.
Code:
<h:commandLink partialSubmit="true"
                              title="#{controller.description}"
                              actionListener="#{controller.actionPerformed}"
                              styleClass="toolbarButtonText"
                              immediate="#{controller.action.immediate}">
                 <ace:ajax/>
                 <img border="0" alt="#{controller.description}"
                      src="#{controller.icon!=null?(controller.icon):(sessionContext.styleManager.zeroIcon)}"/>
                 <h:outputText value="#{controller.title}"
                                 rendered="#{controller.icon==null}"/>
             </h:commandLink>

Action performance executes, no erros in logs (server side and client in browser), event is triggered in the browser. But nothing happens.

I'm use IceFaces 4.2. It's works in IceFaces 3.

UPD: Okay, it looks like for some buttons the problem is this one
Code:
<ace:fileEntry id="fileEntryC"
                                relativePath="#{editor.uploadDirectory}"
                                fileEntryListener="#{editor.action}"
                                useOriginalFilename="false"
                                useSessionSubdir="true"
                                autoUpload="false"
                                maxFileCount="#{f.max}"/>

If I comment this, then some buttons start to work. I tried to wrap this with a <ace:panel> and <h:form>, but it did not work.
petersh

Joined: 14/Jun/2018 20:45:50
Messages: 1
Offline


I think you may want to try with other function instead of Session.
Thus, have you tried to fix your Java code in the live debug mode?
Maksim_A

Joined: 27/Feb/2018 02:01:24
Messages: 18
Offline


petersh wrote:
I think you may want to try with other function instead of Session.
Thus, have you tried to fix your Java code in the live debug mode? 

The problem is that the action is not called. When I click on a button, the result simply does not reach the server and the code is not called.
Maksim_A

Joined: 27/Feb/2018 02:01:24
Messages: 18
Offline


Maksim_A wrote:

petersh wrote:
I think you may want to try with other function instead of Session.
Thus, have you tried to fix your Java code in the live debug mode? 

The problem is that the action is not called. When I click on a button, the result simply does not reach the server and the code is not called. 

I mean this action: fileEntryListener
 
Forum Index -> General Help
Go to:   
Powered by JForum 2.1.7ice © JForum Team