voyent
Using Icefaces within Liferay Portlets - Problems with sorted header  XML
Forum Index -> Portals & Portlets
Author Message
thomas.kumke

Joined: 12/Jul/2007 00:00:00
Messages: 3
Offline


Hi,

i'm working for the Ottgroup in Hamburg and we want to use Icefaces within our new portal solution (Liferay). After the Icefaces version 1.6 and Liferay Portal version 4.3.0 was released we were optimistic to use Icefaces within our portlets.

But we encounter still some problems. Maybe someone could help me to find the errors i have made or there is still a problem with the compatibility?

I want to use a sorted header in a simple test application, but nothing happens when clicking on the header to sort a column. So far i investigated the circumstances the table is sorted in the background but the the client does not show the new sorted table.

the example works, when deploying as normal web application within tomcat but not as a portlet. Furthermore no error messages are logged.

The portal page has no other portlets on it, just the icefaces portlet :-). I read about the problems when using icefaces portlets with other portlets on one page.

The portlet application is attached.


 Filename CTRL-M-Portal-AnalysisPortlet.war [Disk] Download
 Description Portlet application using sorted header
 Filesize 7303 Kbytes
 Downloaded:  203 time(s)


Thomas Kumke
Telpochyaotl

Joined: 23/Apr/2007 00:00:00
Messages: 21
Offline


i can't give you help in your particular problem.

What i can say is that yesterday i checked out Liferay from svn and my sample IceFaces portlet worked fine along with struts based and my faces based portlets... Hoping for a 4.3.1 soon!

I really hope all IceFaces components work too!
michael.thiem


Joined: 04/Jun/2007 00:00:00
Messages: 704
Offline


Hi Thomas,

the attached war file can't be deployed on tocat 5.5. Could you have a look at
it please and send an updated version?

I'll have a look at it then.

Regards,
Michael
thomas.kumke

Joined: 12/Jul/2007 00:00:00
Messages: 3
Offline


Hello Michael,

this war - file is not a normal web application you can simply deploy on a tomcat 5.5. This is a portlet you can deploy within liferay. and therefore you need a tomcat version 6.0. After starting liferay you can put this war in the auto deploy directory and then it should automatically deployed by liferay portal. This works, i tried this 10 minutes ago :-).

Regards,
Thomas
thomas.kumke

Joined: 12/Jul/2007 00:00:00
Messages: 3
Offline


Hello All,

i get it now working. The problem was not Liferay nor Icefaces. It was an old version of the Firefox Browser. I was using version 2.0 and now i using version 2.0.0.5 it is working. Nevertheless the problem is still present with internet explorer. Maybe i try to update this browser too :-).

Thomas

Thomas Kumke
 
Forum Index -> Portals & Portlets
Go to:   
Powered by JForum 2.1.7ice © JForum Team