voyent
Icefaces + netbeans + Vista problem  XML
Forum Index -> General Help
Author Message
GuntherD

Joined: 09/Sep/2007 00:00:00
Messages: 10
Offline


Hi all,

I'm running netbeans 5.5.1 with VWP and icefaces on a vista machine. I'm having trouble getting icefaces to run in this configuration. I keep getting FileNotFoundExceptions, which are due to an 'access denied' exception on the web-directory (see the error message below - for those of you that do not understand dutch, Toegang geweigerd means access denied).

I'm not having this problem on a similar project running on a XP machine, so this is probably due to a Vista security setting. I have already checked rights on the folder, and that seems OK. Anybody has any ideas?

Here's the error message :

9-sep-2007 22:39:20 org.apache.catalina.core.StandardWrapperValve invoke
SEVERE: Servlet.service() for servlet Persistent Faces Servlet threw exception
java.io.FileNotFoundException: C:\Users\Gunther\WebApplication4\build\web (Toegang geweigerd)
at java.io.FileInputStream.open(Native Method)
at java.io.FileInputStream.<init>(FileInputStream.java:106)
at com.icesoft.faces.webapp.http.core.FileServer$1.respond(FileServer.java:35)
at com.icesoft.faces.webapp.http.common.standard.CompressingServer$CompressingRequest$1.respond(CompressingServer.java:44)
at com.icesoft.faces.webapp.http.servlet.ServletRequestResponse.respondWith(ServletRequestResponse.java:143)
at com.icesoft.faces.webapp.http.common.standard.CompressingServer$CompressingRequest.respondWith(CompressingServer.java:41)
at com.icesoft.faces.webapp.http.core.FileServer.service(FileServer.java:28)
at com.icesoft.faces.webapp.http.common.standard.PathDispatcherServer$Matcher.serviceOnMatch(PathDispatcherServer.java:50)
at com.icesoft.faces.webapp.http.common.standard.PathDispatcherServer.service(PathDispatcherServer.java:19)
at com.icesoft.faces.webapp.http.common.standard.CompressingServer.service(CompressingServer.java:25)
at com.icesoft.faces.webapp.http.core.ResourceServer.service(ResourceServer.java:30)
at com.icesoft.faces.webapp.http.servlet.BasicAdaptingServlet.service(BasicAdaptingServlet.java:16)
at com.icesoft.faces.webapp.http.servlet.PathDispatcher$Matcher.serviceOnMatch(PathDispatcher.java:52)
at com.icesoft.faces.webapp.http.servlet.PathDispatcher.service(PathDispatcher.java:29)
at com.icesoft.faces.webapp.http.servlet.MainServlet.service(MainServlet.java:98)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
at org.netbeans.modules.web.monitor.server.MonitorFilter.doFilter(MonitorFilter.java:368)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:664)
at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)
at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
at java.lang.Thread.run(Thread.java:619)


Thanks for your help.
licensekeyto@hotmail.com

Joined: 09/May/2007 00:00:00
Messages: 5
Offline


Hi Gunther,

I (also dutch speaking) have the same problem on XP PRO SP2 within JBoss 4.0.5. TMP directory is not accessable for my ICEFaces application. On another machine, also XP PRO SP2 the application runs fine... I'll keep on searching for the differences... Did you find the solution yet?

Regards,
Kurt
licensekeyto@hotmail.com

Joined: 09/May/2007 00:00:00
Messages: 5
Offline


Hi Gunther,

I found out that it has something to do with permissions for file-upload.
Since I don't use this functionality, I removed the upload directory and the maximum upload size from web.xml which solved the problem.
Perhaps this is usefull for you for know and for all other people out there experiencing the same problem.

Kurt
GuntherD

Joined: 09/Sep/2007 00:00:00
Messages: 10
Offline


Hey Kurt,

is does indeed seem that the problem lies with some of the iceface modules, since I removed some iceface references from the web.xml too, and got it working that way.

Thanks for the feedback,
Gunther
 
Forum Index -> General Help
Go to:   
Powered by JForum 2.1.7ice © JForum Team