voyent
Errors when deployed on Sun App Server and Weblogic 10.0  XML
Forum Index -> WebMC
Author Message
phuong.nguyen

Joined: 23/Oct/2007 00:00:00
Messages: 9
Offline


I tried both to compile the code and use the war file from the binary zip file, they gave me the same errors, describe as follow:

1. Tomcat 6: only works if remove 2 jar from the war file: el-api.jar and xercesImpl.jar
- After login to a presentation, keep the browser window idle for a while (say 10 minutes), come back and a dialog saying the session expired, click OK and received error "Tomcat 6.0: session expired dialog, press OK and received error:

javax.faces.FacesException: Can't parse stream for /index.jspx Failed to execute JSP lifecycle.
at com.icesoft.faces.application.D2DViewHandler.renderResponse(D2DViewHandler.java:525)"

2. Sun App server 9.1 PE:

- could not start webmc with the original webmc.war

- without el-api.jar and xercesImpl.jar:
see the starting webmc site, when click start, received the error: "java.lang.IllegalArgumentException: Cannot invoke javax.faces.webapp.ValidatorTag.setValidatorId - argument type mismatch"


3. Weblogic server 10.0

- raised no error msg, but could not upload a new presentation, clicking upload button just do nothing(I am new to weblogic server, may be I should assign the right to upload file to the webmc app)


Does anyone know what the reasons are? all these errors are reproducible as I tried several times on the servers.

Thanks in advance for any suggestion

Phuong
 
Forum Index -> WebMC
Go to:   
Powered by JForum 2.1.7ice © JForum Team