voyent
[SOLVED] Server push not working on the latest svn version  XML
Forum Index -> Development Build Feedback
Author Message
edykory


Joined: 27/Nov/2006 00:00:00
Messages: 332
Offline


Hi, I'm using some very simple sever push thing (a progress bar which gets updated by a working thread). On the Ice Faces version I took on Nov 28 everything was ok, on the latest one (Dec 06) I get some
12:30:34,969 ERROR [View] Failed to notify listener: com.icesoft.faces.context.View$4@412739
com.icesoft.util.PropertyException: value is not an int: null
at com.icesoft.util.Properties.getIntProperty(Properties.java:410)
at com.icesoft.net.messaging.MessageServiceConfigurationProperties.getMessageMaxLength(MessageServiceConfigurationProperties.java:102)
at com.icesoft.net.messaging.MessagePipeline.enqueue(MessagePipeline.java:136)
at com.icesoft.net.messaging.MessageServiceClient.publish(MessageServiceClient.java:922)
at com.icesoft.net.messaging.MessageServiceClient.publish(MessageServiceClient.java:493)
at com.icesoft.net.messaging.MessageServiceClient.publish(MessageServiceClient.java:604)
at com.icesoft.faces.async.server.AsyncHttpServerAdaptingServlet$2.run(AsyncHttpServerAdaptingServlet.java:114)
at com.icesoft.faces.webapp.http.core.ViewQueue.put(ViewQueue.java:16)
at com.icesoft.faces.context.View$4.run(View.java:81)
at com.icesoft.faces.context.View.broadcastTo(View.java:183)
at com.icesoft.faces.context.View.put(View.java:158)
at com.icesoft.faces.context.PushModeSerializer.serialize(PushModeSerializer.java:64)
at com.icesoft.faces.context.DOMResponseWriter.endDocument(DOMResponseWriter.java:183)
at com.icesoft.faces.facelets.D2DFaceletViewHandler.renderResponse(D2DFaceletViewHandler.java:321)
at com.icesoft.faces.application.D2DViewHandler.renderView(D2DViewHandler.java:151)
at com.sun.faces.lifecycle.RenderResponsePhase.execute(RenderResponsePhase.java:106)
at com.sun.faces.lifecycle.LifecycleImpl.phase(LifecycleImpl.java:251)
at com.sun.faces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:144)
at com.icesoft.faces.webapp.xmlhttp.PersistentFacesState.render(PersistentFacesState.java:145)
at com.icesoft.faces.async.render.RunnableRender.run(RunnableRender.java:142)
at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:665)
at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:690)
at java.lang.Thread.run(Unknown Source) 


Cheers!
edykory


Joined: 27/Nov/2006 00:00:00
Messages: 332
Offline


It was caused by the presence of icefaces-ahs.jar in my /WEB-INF/lib folder without any web.xml configuration. I had a failed attempt to use AHS in my application (I'm waiting for some answers on that on another post) and hot redeploying my app didn't remove that one.

Eduard
 
Forum Index -> Development Build Feedback
Go to:   
Powered by JForum 2.1.7ice © JForum Team