voyent
problems with panelTabSet  XML
Forum Index -> Components
Author Message
adjoh

Joined: 27/Jan/2006 00:00:00
Messages: 3
Offline


I am trying to use a panelTabSet, but encounter two problems:

1: by default, the panelTabs are displayed in the browser without any style (eg. plain text). I tried to "decorate" them using the attribues 'activeTabStyleClass' and 'inActiveTabStyleClass' which gives the respected result as the page is first rendered. But when clicking on one of the tabs with the mouse, the panelTabs loose the attributed style. Any idea how to cope with this?

2: When the panelTabSet is in a .jspx page it is rendered. But if I put it in a .jsp page which is included in a .jspx page (the template) the panelTabSet doesn't show at all...

I would be very greatfull, if anyone could help me out.
gregory_m

Joined: 17/Jan/2005 00:00:00
Messages: 130
Offline


Here are a couple things you can try.

1) Make sure you have a valid css link defined in the head of your .jspx page. The link below will use the xp.css that is included in the icefaces.jar.

<head><title>panelTabSet example</title>
<link rel="stylesheet" type="text/css" href="./xmlhttp/css/xp/xp.css"/>
</head>


2) Including a jsp in your jspx page should work using jsp:directive.include.

<jsp:directive.include file="./inc/yourTab.jsp" />


Message was edited by: gregory_m
gregory_m

Joined: 17/Jan/2005 00:00:00
Messages: 130
Offline


Here's the missing link and include.

1) <head><title>panelTabSet example</title>
<link rel="stylesheet" type="text/css" href="./xmlhttp/css/xp/xp.css"/>
</head>

2) <jsp:directive.include file="./inc/yourTab.jsp" />


Message was edited by: gregory_m
adjoh

Joined: 27/Jan/2006 00:00:00
Messages: 3
Offline


Thank you for your answer, Gregory.

My code was already very similar to what you propose. I no longer have the problem with the panelTabSet not rendering on an included jsp page (don't really know why...), but the style problem is still there. Actually, the problem occurs when I want to change the active tab (with the mouse). This results in the tabs loosing their style and "moving" on the page????
gregory_m

Joined: 17/Jan/2005 00:00:00
Messages: 130
Offline


You're welcome adjoh,

I have a question.

Is the stylesheet link in your .jspx page or the included .jsp page ?

It would be helpful if I could take a look at your pages.
Please email/send your source code to product.support@icesoft.com

Thanks.


Message was edited by: gregory_m
adjoh

Joined: 27/Jan/2006 00:00:00
Messages: 3
Offline


Hi again,

I just sent you my code.

Thank you again.

Ane
gregory_m

Joined: 17/Jan/2005 00:00:00
Messages: 130
Offline


Hello Ane,

I have reviewed your source code. The problem you are experiencing is being caused by an issue in the css file.
I have modified your css file, our support team will be sending you the updated css and a more detailed description shortly.

In the ICEfaces-0.3.0-Alpha release, /resource/css/ directory, we have included 2 css themes; xp and royale. When creating your own custom theme you should copy and edit one of these themes to suite your needs.

Please refer to pages 40-41, "Look & Feel Customization (Themes)", in the ICEfacesDevelopersGuide.pdf for more information.

Thank you for your patience and interest in ICEfaces.

Greg


Message was edited by: gregory_m
 
Forum Index -> Components
Go to:   
Powered by JForum 2.1.7ice © JForum Team