voyent
Heatbeating goes crazy with AHS configured  XML
Forum Index -> Async HTTP Server
Author Message
edykory


Joined: 27/Nov/2006 00:00:00
Messages: 332
Offline


Hi there!
I have this application running on JBoss 4.2, JDK 5, IceFaces 1.7DR#3 (nonclustered).
I tried to configure our application with the AHS and it looks like something's going "not so right". The configuration was done exactly like in the online documentation, but here is the issue:
1. The application has the heartbeating mechanism configured to pulse at 10 seconds interval (with an 8s timeout). Without the AHS this is going exactly as expected (could tell that from the Firebug console log).
2. Once I add the icefaces-ahs.jar and put the two parameters in web.xml, the console shows that instead of running at a 10s interval, the heart-beating runs maybe 5 times a second or even more often, I just see hundreds of lines written in the console also with the following error:

POST http://localhost:8080/OTPProject/block/receive-updated-views (15ms)icefaces-d2d.js (line 1469)
[window.W5Kb#4.async-connection] closing previous connection...icefaces-d2d.js (line 1331)
[window.W5Kb#4.async-connection.blocking] [7325539] : connection closedicefaces-d2d.js (line 1331)
[window.W5Kb#4.async-connection] connect...icefaces-d2d.js (line 1331)
[window.W5Kb#4.async-connection.blocking] [7384555] : send asynchronous POSTicefaces-d2d.js (line 1331)
[window.W5Kb#4.async-connection.blocking] [7384555] : receive [200] OKicefaces-d2d.js (line 1331)
[window.W5Kb#4.async-connection] receive broadcast failed TypeError: _355.contentAsDOM() has no properties message=_355.contentAsDOM() has no propertiesicefaces-d2d.js (line 1337)
POST http://localhost:8080/OTPProject/block/receive-updated-views (0ms)icefaces-d2d.js (line 1469)
[window.W5Kb#4.async-connection] closing previous connection...icefaces-d2d.js (line 1331)
[window.W5Kb#4.async-connection.blocking] [7384555] : connection closedicefaces-d2d.js (line 1331)
[window.W5Kb#4.async-connection] connect...icefaces-d2d.js (line 1331)
[window.W5Kb#4.async-connection.blocking] [5371599] : send asynchronous POSTicefaces-d2d.js (line 1331)
[window.W5Kb#4.async-connection.blocking] [5371599] : receive [200] OKicefaces-d2d.js (line 1331)
[window.W5Kb#4.async-connection] receive broadcast failed TypeError: _355.contentAsDOM() has no properties message=_355.contentAsDOM() has no propertiesicefaces-d2d.js (line 1337)
POST http://localhost:8080/OTPProject/block/receive-updated-views (0ms)icefaces-d2d.js (line 1469)
[window.W5Kb#4.async-connection] closing previous connection...icefaces-d2d.js (line 1331)
[window.W5Kb#4.async-connection.blocking] [5371599] : connection closedicefaces-d2d.js (line 1331)
[window.W5Kb#4.async-connection] connect...icefaces-d2d.js (line 1331)
[window.W5Kb#4.async-connection.blocking] [517951] : send asynchronous POSTicefaces-d2d.js (line 1331)
[window.W5Kb#4.async-connection.blocking] [517951] : receive [200] OKicefaces-d2d.js (line 1331)
[window.W5Kb#4.async-connection] receive broadcast failed TypeError: _355.contentAsDOM() has no properties message=_355.contentAsDOM() has no propertiesicefaces-d2d.js (line 1337)
POST http://localhost:8080/OTPProject/block/receive-updated-views (0ms)icefaces-d2d.js (line 1469)
[window.W5Kb#4.async-connection] closing previous connection...icefaces-d2d.js (line 1331)
[window.W5Kb#4.async-connection.blocking] [517951] : connection closedicefaces-d2d.js (line 1331)
[window.W5Kb#4.async-connection] connect...icefaces-d2d.js (line 1331)
[window.W5Kb#4.async-connection.blocking] [4576641] : send asynchronous POSTicefaces-d2d.js (line 1331)
[window.W5Kb#4.async-connection.blocking] [4576641] : receive [200] OKicefaces-d2d.js (line 1331)
[window.W5Kb#4.async-connection] receive broadcast failed TypeError: _355.contentAsDOM() has no properties message=_355.contentAsDOM() has no propertiesicefaces-d2d.js (line 1337)
 

In the server logs there are no complains, no exceptions, the JMS configuration shows that everything is ok for the ahs server and for my app, so it's just this crazy-like behavior with hundreds of requests per second that worries me (beside the Javascript error message).

Any ideas?

Eduard
jack.van.ooststroom


Joined: 26/Oct/2004 00:00:00
Messages: 223
Offline


Hi Eduard,

Sorry, I totally missed your post here. If you're still experiencing this problem, can you please post your application's web.xml? Did you deploy the async-http-server.war as well? Did you configure the AHS to run in servlet or in server mode?

Regards,
Jack...

Jack van Ooststroom
Senior Developer
ICEsoft Technologies, Inc.
[Email]
 
Forum Index -> Async HTTP Server
Go to:   
Powered by JForum 2.1.7ice © JForum Team