voyent
liferay partial submit problem  XML
Forum Index -> Portals & Portlets
Author Message
Ragnarok

Joined: 27/Jan/2008 00:00:00
Messages: 12
Offline


I have a problem, the first time the portlet appers this:
<ice:outputText renderedOnUserRole="administrator" value="IM ADMIN!!"/>
works very well, but when I do a partial submit of any kind (button, valuechange, etc), the message doesnt appears anymore and this is a property from a managed bean, the first time this works well, returning the firstname:

public String getName() {
try {

User usr = UserServiceUtil.getUserById(10720);
return usr.getFirstName();
} catch (Exception ex) {
return ex.getMessage() + ex.getLocalizedMessage() + ex.toString();
}
}

but the second one, when doing a partial submit, give me a NPE!!

Any help?? looks like this is a session problem... or is this a bug??


Thanks a lot!!!
dlucas8

Joined: 20/Mar/2008 00:00:00
Messages: 65
Offline


I am having similar problems with session attributes. I have yet to receive an answer from IceFaaces or Liferay. I cannot access session attributes that are shared from the portal to the portlets. It was working fine in a JSF portlet but as soon as I changed to a ICEFaces portlet my attributes disappeared.
Ragnarok

Joined: 27/Jan/2008 00:00:00
Messages: 12
Offline


including those lines in the liferay-portlet.xml file:

<private-request-attributes>false</private-request-attributes>
<private-session-attributes>false</private-session-attributes>

always shows the session expired message.

Thanks
 
Forum Index -> Portals & Portlets
Go to:   
Powered by JForum 2.1.7ice © JForum Team