voyent
navigation broken  XML
Forum Index -> General Help
Author Message
JerryPan

Joined: 15/Jan/2008 00:00:00
Messages: 2
Offline


Can anyone help?
After updating from 1.6 to 1.7, my navigation is broken: an action button's action, "next" used to render the next page, but it does nothing now.

code segment in faces-config.xml:

==========================
Code:
<!--  Navaigations  -->
 	<!-- Site Page -->
 	<navigation-rule>
 		<from-view-id>/site.iface</from-view-id>
 		<navigation-case>
 			<from-outcome>next</from-outcome>
 			<to-view-id>/var_ds.iface</to-view-id>
 			<redirect />
 		</navigation-case>
 	</navigation-rule>

[/code]
===========================

code segment in site.jspx:
========================

[code]<ice:panelGrid border="0" columns="10" style="margin-left: 450px" cellspacing="5" cellpadding="5" rowClasses="RtBtm">

<ice:commandButton id="sitePageNext" action="next" image="images/next-32x32.png" immediate="true" partialSubmit="false" title="next">
</ice:commandButton>
</ice:panelGrid>
[/code]

===================================
qpid

Joined: 09/Nov/2007 00:00:00
Messages: 21
Offline


Hi JerryPan,

try to use in the from-view-id the name of the site extended by jspx

this one is working for me:

Code:
<navigation-rule>
 		<from-view-id>/site.jspx</from-view-id>
 		<navigation-case>
 			<from-outcome>next</from-outcome>
 			<to-view-id>/var_ds.iface</to-view-id>
 <redirect />
 		</navigation-case>
 	</navigation-rule>


regards qpid
JerryPan

Joined: 15/Jan/2008 00:00:00
Messages: 2
Offline


Well, that change did not work for me. I am wondering what is the difference between your env and mine?
qpid

Joined: 09/Nov/2007 00:00:00
Messages: 21
Offline


its not clear for me what you are mean with what is the difference? Are you asking yourself or really didn't see the difference. In second case:
<from-view-id>/site.iface</from-view-id>
=>
<from-view-id>/site.jspx</from-view-id>

regards qpid
 
Forum Index -> General Help
Go to:   
Powered by JForum 2.1.7ice © JForum Team