voyent
Messages posted by: kvindum  XML
Profile for kvindum -> Messages posted by kvindum [5]
Author Message
I'm curious if anyone else has seen this exception?

I'm using IcePush 4.2.0 and Java 1.8.0_191. The exception isn't thrown instantly when the application starts. It takes a while before it happens but keeps happening when the scenario first starts.

java.lang.NullPointerException
at java.util.concurrent.ConcurrentHashMap.get(ConcurrentHashMap.java:936)
at java.util.Collections$UnmodifiableMap.get(Collections.java:1454)
at org.icepush.LocalPushGroupManager.getPushID(LocalPushGroupManager.java:244)
at org.icepush.LocalPushGroupManager$Notification.run(LocalPushGroupManager.java:898)
at org.icepush.LocalPushGroupManager$QueueConsumerTask.run(LocalPushGroupManager.java:1003)
at java.util.TimerThread.mainLoop(Timer.java:555)
at java.util.TimerThread.run(Timer.java:505)
I've recently upgraded to Icefaces 4.2.0, and have discovered that jqPlot has stopped working. I'm not using the ace:chart, but have made a custom implementation of jqplot. This worked fine in Icefaces 4.1.1 but broke in Icefaces 4.2.0

This simple example doesn't work with Icefaces 4.2.0
Code:
 <html xmlns="http://www.w3.org/1999/xhtml"
       xmlns:h="http://java.sun.com/jsf/html"
       xmlns:f="http://java.sun.com/jsf/core">
     <f:view contentType="text/html">
         <h:head>
             <h:outputScript name="jquery.min.js" library="js" target="head"/>
             <h:outputScript name="jquery.jqplot.min.js" library="js" target="head"/>
             <h:outputStylesheet name="jquery.jqplot.css" library="css"/>
         </h:head>
         <h:body>
                 <script type="text/javascript">
                     $(document).ready(function () {
                         $.jqplot('chartdiv', [[[1, 2], [3, 5.12], [5, 13.1], [7, 33.6], [9, 85.9], [11, 219.9]]]);
                     });
                 </script>
                 <div id="chartdiv" style="height:400px;width:300px; "></div>
         </h:body>
     </f:view>
 </html>
 


The code works just fine if I downgrade to Icefaces 4.1.1.

Can you give a clue to why $.jqplot is no longer working?

Kind regards
Kenneth Vindum
Hi Ken

I've just updated to 4.2.0, and the components now work like a charm.

Thank you for the quick solution to this problem.
I'm trying to use the disabled property of the ace:pushbutton, but it only seems to cause the graphical part of the button to become disabled. The button can still be clicked, and still carries out events.
This is the same for ace:linkButton. I've tested in Icefaces 4.1.1 and 4.2.0.BETA

Code:
 <ace:pushButton value="Show Alert" disabled="true" >
     <f:passThroughAttribute name="onclick" value="alert('test')"/>
 </ace:pushButton>
 


I've also tried to use <ace:ajax> using onStart, but this also doesn't disable the functionality.
A workaround is to use the disabled property of both the ace:pushButton and the ace:ajax tags. This does however seem rather redundant to me... Changing the implementation to h:commandButton will also make the error go away, but isn't quite the the Icefaces way.

Is the described behavior an error, or am I using the library in a wrong way?
Kind regards
Kenneth Vindum
Hi Forum

I've recently been working with Icefaces 4.1.1 and TomEE 7.0.2, and I'm experiencing the following error 11 times during statup.

08-Dec-2016 08:17:11.566 SEVERE [localhost-startStop-1] org.apache.openejb.config.AnnotationDeployer$ProcessAnnotatedBeans.deploy Unable to load tag library tag class:

The error disappears if I remove the Icefaces dependency. I've tried downgrading Icefaces to 3.2.0, which reduces the number of occurrences I see the error, but it doesn't make it go away.

It's quite easy to replicate the error. Just create a Maven web project in Netbeans 8.1 and add icefaces-ace 4.1.1 to the pom. Deploy the result to TomEE plume 7.0.2. The server is running the default version 2.2.12 of Mojarra.

The web application does seem to be working, but I'm asking anyway, as the log-statement is marked as SEVERE.

Any ideas what is going on, and if it can be fixed somehow?

Kind Regards
Kenneth
 
Profile for kvindum -> Messages posted by kvindum [5]
Go to:   
Powered by JForum 2.1.7ice © JForum Team