voyent
Messages posted by: philip.breau  XML
Profile for philip.breau -> Messages posted by philip.breau [2745] Go to Page: Previous  1, 2, 3 , 4, 5, 6 ... 181, 182, 183 Next 
Author Message
Have you tried just using an h:inputText with f:ajax? Partial Submit is a legacy attribute for the older ice components.
Here you go. There's also more info here.
Hi,
First you might try out 3.3. Ajax request coalescing was added in 3.2, which might solve your problem. Although I haven't tested this with partialSubmit, and it might only be with ace:ajax requests. Could you post your xhtml?

Philip
Great. 3.3 GA should be out very shortly. I'd recommend keeping all the ice jars in sync and there'll be a jump in the MyFaces version as well.

Thanks
I can reproduce this problem on 3.2, but not on 3.3 RC1. Could you try 3.3 RC1 to see if that fixes the problem?
Have you deployed EPS with the recommended configuration for Glassfish as well as configured JMS? Is this a new deployment configuration? Has anything changed in your configuration?
Also, do you see the same issue when the application is not deployed in a cluster?
Can you give any other information? Do the exceptions happen randomly? How long have you set the session timeout too and when do the exceptions happen? Are there any other wrapped exceptions in the logs? Perhaps also post the browser logs. Can you reproduce it in test case?
Are these session timeouts expected, or are the exceptions happening before a session has actually timed out? Is the exception and stack trace only visible in the logs, or is the end user seeing any error?
Have you tried clearing your cookies?
Are you including all of the icefaces/icepush jars in the war WEB-INF/lib folder (and not the ear lib)? Do you see another log signature for ICEpush? Perhaps you could also try 3.2 to see if the problem persists there. Also double check that all of the jars are from the same ICEfaces release version.
Make sure that the jsf jars are included in your war lib and try including this in your web.xml:
Code:
 <context-param>
         <param-name>org.jboss.jbossfaces.WAR_BUNDLES_JSF_IMPL</param-name>
         <param-value>true</param-value>
     </context-param>
 
Perhaps the default jvm time zone is set to GMT, which might be rolling over from your local date. Try setting the time zone manually to your local:

Code:
 public TimeZone getTimeZone() {
        return TimeZone.getTimeZone("Asia/Shanghai");
  }
 
I posted the link above to the api.
Yes, for me, testing with trunk, the problem seems to go away when you remove the ace:panel or the ace:ajax tag.
 
Profile for philip.breau -> Messages posted by philip.breau [2745] Go to Page: Previous  1, 2, 3 , 4, 5, 6 ... 181, 182, 183 Next 
Go to:   
Powered by JForum 2.1.7ice © JForum Team