voyent
Messages posted by: judy.guglielmin  XML
Profile for judy.guglielmin -> Messages posted by judy.guglielmin [576] Go to Page: 1, 2, 3  ...  37, 38, 39 Next 
Author Message
It sounds like your page may not be loading all the resources correctly so that the components may not be fully initialized---check your browser console to see if there are any javascript errors...that would be my first guess. Check to also see that the page is actually ready if you are using custom javascript.
It sounds like your page is not loading all the resources correctly so that the components may not be fully initialized---check your browser console to see if there are any javascript errors...that would be my first guess. Check to also see that the page is actually ready if you are using custom javascript.
Hello.
That is definitely on our list of things to be done, but meanwhile, just add this to your repository listings
<repository>
<id>snapshots</id>
<url>http://anonsvn.icefaces.org/repo/maven2/releases/</url>
</repository>
That is correct. The ice (compat library) components have been replaced by the ace component library in ICEfaces 4.x
Please see
http://www.icesoft.org/wiki/display/ICE/ICE+to+ACE+Component+Migration+Guide

where it explains component by component for migration purposes.
A couple things to note....
1) ICEfaces 4 requires JSF 2.2
2) the compat (ice namespace components) are no longer available in ICEfaces 4. you must use the ace component library

There have been no issues raised since any of the 4.x releases for general performance. You would need to be more specific as well. Have you used a profiler for a particular view that customers are complaining about? Since the ice components are available in ICEfaces 3.3.x and not in ICEfaces 4.x, did you change from an ice component to an ace component (tabSet) and are not aware of the caching options on ace:tabSet?
http://www.icesoft.org/wiki/display/ICE/TabSet
If you are interested in a support option to help with your issue (plus have access to ICEfaces-ee downloads), that is also a way to assist with your (more) specific issue.

I'm not sure what version you are using, but the latest downloads for enterprise users (3.3.0_P05) contains a reworking of how the alignment is done for headers of the data table (there are other jiras as well fixed in earlier enterprise editions, but the most recent is always best!).

I suggest you do a search in our Jira system to see if you can find the exact issue you are looking at as you are not providing a lot of detail.

http://jira.icesoft.org/
Most users found this issue was caused by either having duplicate ICEfaces or JSF jars in the classpath or incorrect ui:composition markup in the xhtml page.
You can search older postings in this forum. One that might help is:-

http://www.icesoft.org/JForum/posts/list/22121.page#sthash.WwatmhH3.dpbs

Another cause could be incorrect using of component binding (using the "binding" attribute on a component that is not in @RequestScoped).

yes, the compat (ice) components are not part of the ICEfaces 4/JSF 2.2 configuration. PLease review http://www.icesoft.org/wiki/display/ICE/ICEfaces+3+to+4+Migration+Guide

to assist you in replacing the ice/compat components.

Please review the migration guide located here:-
http://www.icesoft.org/wiki/display/ICE/ICEfaces+3+to+4+Migration+Guide

for eclipse to maven, it depends on if you want to use the eclipse plugin or not, a general google search will assist you in this manner and it's best to review the docs for the version of eclipse you are using.
If you just want the cursor symbol to change, you could use some javascript using the <ace:ajax onStart="jsFunctionChangeToBusyCursor" onComplete="jsFunctionChangeToNormalCursor"....../> on the <ace:pushButton/> or <ace:linkButton/> or whatever ace component does the submit.


The icecore:defaultAction will allow you to specify the enter key on a form:-
http://www.icesoft.org/wiki/display/ICE/defaultAction

also, if you do not have an action or actionListener attribute on the ace:pushButton, you could use type="submit" on the ace:pushButton.
Have you reviewed the information located here:-
http://www.icesoft.org/wiki/display/ICE/SubmitMonitor

You can configure the submitMonitor for a single area of the form or the entire page.
Please post markup as well as any console logging errors/server errors if you are still having issues.

Thanks.
Hello Peter.
This issue has been resolved in the recent 4.2.0-EE release.
As a supported customer I recommend that you create a new Support Case via our Self-Service Portal so we can provide priority support.  Let us know if you have issues with accessing the portal by emailing product support.
 
Profile for judy.guglielmin -> Messages posted by judy.guglielmin [576] Go to Page: 1, 2, 3  ...  37, 38, 39 Next 
Go to:   
Powered by JForum 2.1.7ice © JForum Team