Supported Platforms

Table of Contents


ICEpdf requires a compliant Java Virtual Machine (JVM) that supports Java 2D and JFC (Swing). Typically, any J2SE platform, version 1.8.0 or greater, meets these requirements. The officially supported platform and JVM combinations are:

Windows
  • Oracle JDK 8.0
  • Oracle JDK 9.0
Linux
  • Oracle JDK 8.0
  • Oracle JDK 9.0
Mac OS X
  • Oracle JDK 8.0
  • Oracle JDK 9.0

Support for JDK version 1.5 is available upon request, contact ICEsoft support for more information.

Enter labels to add to this page:
Please wait 
Looking for a label? Just start typing.

© Copyright 2017 ICEsoft Technologies Canada Corp.