voyent
ICEfaces 1.7.2 IDE integration status  XML
Forum Index -> Tools
Author Message
ken.fyten

Joined: 26/Oct/2004 00:00:00
Messages: 1346
Offline


Hello,

Now that 1.7.2 has shipped, I just wanted to let you know that the updated IDE integration bundles with 1.7.2 should be available within the next couple of days. This includes Eclipse 3.4, Netbeans 6.1, and MyEclipse 6.5.

Regards,
Ken

Ken Fyten
VP Product Development
ICEsoft Technologies, Inc.
thewolf


Joined: 04/Jan/2008 00:00:00
Messages: 128
Offline


Does that also include Eclipse 3.3?
ken.fyten

Joined: 26/Oct/2004 00:00:00
Messages: 1346
Offline


We will not be releasing an Eclipse 3.3 integration for 1.7.2 (just Eclipse 3.4), but you should be able to manually upgrade the ICEfaces libraries being used for the older 1.7.1 integration.

Regards,
Ken

Ken Fyten
VP Product Development
ICEsoft Technologies, Inc.
ken.fyten

Joined: 26/Oct/2004 00:00:00
Messages: 1346
Offline


Hello,

The Eclipse 3.4 and Netbeans 6.1 integration bundles for 1.7.2 are available now.

Regards,
Ken

Ken Fyten
VP Product Development
ICEsoft Technologies, Inc.
connolly.st


Joined: 05/Jun/2008 00:00:00
Messages: 89
Offline


Excellent, thanks for the quick turnaround guys!
thewolf


Joined: 04/Jan/2008 00:00:00
Messages: 128
Offline


ken.fyten wrote:
We will not be releasing an Eclipse 3.3 integration for 1.7.2 (just Eclipse 3.4), but you should be able to manually upgrade the ICEfaces libraries being used for the older 1.7.1 integration. 


Are there other changes in the Eclipse integration bundle besides the switch to the 1.7.2 libraries and the 3.4 requirement?
sep434

Joined: 19/Mar/2008 00:00:00
Messages: 12
Offline


Hello,

What is the status of the MyEclipse 6.5 plugin? Will it be avaible soon?

Thanks,
Peter
pswag

Joined: 24/Jul/2008 00:00:00
Messages: 36
Offline


Hi,

what about IBM Rational Application Developer 7.5? This is based on Eclipse 3.4.

I have tried to install the Eclipse 3.4 plug-in in RAD 7.5 with no success. It reports following dependency errors:

--- FULL ---
Cannot complete the request. See the details.
Unsatisfied dependency: [org.eclipse.jst.jsf.facelet.feature.feature.group 0.1.0.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jst.jsf.facelet.tagsupport/[0.1.0.200810101024,0.1.0.200810101024]
Unsatisfied dependency: [org.eclipse.jst.jsf.facelet.feature.feature.group 0.1.0.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jst.jsf.facelet.doc.user/[0.1.0.200810101024,0.1.0.200810101024]
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.core.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jst.pagedesigner.jsf.ui/[1.1.0,2.0.0)
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.core.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jst.pagedesigner.jsp.core/[1.1.0,2.0.0)
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.core.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/com.icesoft.ide.eclipse.designtime/[1.7.2.200810101024,1.7.2.200810101024]
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.core.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/com.icesoft.ide.eclipse.icefaces.doc/[1.7.1.200810101024,1.7.1.200810101024]
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.facelets.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/com.icesoft.ide.eclipse.icefaces.facelets/[3.4.1.200810101024,3.4.1.200810101024]
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.core.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/com.icesoft.ide.eclipse.icefaces.core/[3.4.1.200810101024,3.4.1.200810101024]
Unsatisfied dependency: [org.eclipse.jst.jsf.facelet.feature.feature.group 0.1.0.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jst.jsf.facelet.core/[0.1.0.200810101024,0.1.0.200810101024]
Unsatisfied dependency: [com.icesoft.eclipse.sunri.feature.feature.group 1.1.2.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/com.icesoft.eclipse.sunri/[1.1.2.200810101024,1.1.2.200810101024]
Unsatisfied dependency: [org.eclipse.jst.jsf.facelet.feature.feature.group 0.1.0.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jst.jsf.facelet.ui/[0.1.0.200810101024,0.1.0.200810101024]
Unsatisfied dependency: [com.icesoft.eclipse.icefaces.v1.7.2.feature.feature.group 1.0.0.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/com.icesoft.eclipse.icefaces.v172/[1.0.0.200810101024,1.0.0.200810101024]
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.core.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jst.pagedesigner/[1.1.0,2.0.0)
Unsatisfied dependency: [com.icesoft.eclipse.icefaces.v1.7.2.feature.feature.group 1.0.0.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/com.icesoft.eclipse.icefaces.v172/[1.0.0.200810101024,1.0.0.200810101024]
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.core.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jst.pagedesigner/[1.1.0,2.0.0)
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.core.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/com.icesoft.ide.eclipse.icefaces.core/[3.4.1.200810101024,3.4.1.200810101024]
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.core.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/com.icesoft.ide.eclipse.icefaces.doc/[1.7.1.200810101024,1.7.1.200810101024]
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.core.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/com.icesoft.ide.eclipse.designtime/[1.7.2.200810101024,1.7.2.200810101024]
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.core.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jst.pagedesigner.jsf.ui/[1.1.0,2.0.0)
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.core.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jst.pagedesigner.jsp.core/[1.1.0,2.0.0)
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.facelets.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/com.icesoft.ide.eclipse.icefaces.facelets/[3.4.1.200810101024,3.4.1.200810101024]
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.facelets.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jst.jsf.facelet.core/0.1.0
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.facelets.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/com.icesoft.ide.eclipse.icefaces.core/3.4.0
Unsatisfied dependency: [org.eclipse.jst.jsf.facelet.feature.feature.group 0.1.0.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jst.jsf.facelet.ui/[0.1.0.200810101024,0.1.0.200810101024]
Unsatisfied dependency: [org.eclipse.jst.jsf.facelet.feature.feature.group 0.1.0.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jst.jsf.facelet.core/[0.1.0.200810101024,0.1.0.200810101024]
Unsatisfied dependency: [org.eclipse.jst.jsf.facelet.feature.feature.group 0.1.0.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jst.jsf.facelet.doc.user/[0.1.0.200810101024,0.1.0.200810101024]
Unsatisfied dependency: [org.eclipse.jst.jsf.facelet.feature.feature.group 0.1.0.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jst.jsf.facelet.tagsupport/[0.1.0.200810101024,0.1.0.200810101024]
Unsatisfied dependency: [com.icesoft.eclipse.sunri.feature.feature.group 1.1.2.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/com.icesoft.eclipse.sunri/[1.1.2.200810101024,1.1.2.200810101024]

--- ICEFACES ECLIPSE - FACELETS, ICEFACES ECLIPSE INTEGRATION - CORE, ICEFACES v1.7.2. RUNTIME LIBRARY ---
Cannot complete the request. See the details.
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.core.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jst.pagedesigner.jsf.ui/[1.1.0,2.0.0)
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.core.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jst.pagedesigner.jsp.core/[1.1.0,2.0.0)
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.core.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/com.icesoft.ide.eclipse.designtime/[1.7.2.200810101024,1.7.2.200810101024]
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.core.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/com.icesoft.ide.eclipse.icefaces.doc/[1.7.1.200810101024,1.7.1.200810101024]
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.facelets.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/com.icesoft.ide.eclipse.icefaces.facelets/[3.4.1.200810101024,3.4.1.200810101024]
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.core.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/com.icesoft.ide.eclipse.icefaces.core/[3.4.1.200810101024,3.4.1.200810101024]
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.facelets.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jst.jsf.facelet.core/0.1.0
Unsatisfied dependency: [com.icesoft.eclipse.icefaces.v1.7.2.feature.feature.group 1.0.0.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/com.icesoft.eclipse.icefaces.v172/[1.0.0.200810101024,1.0.0.200810101024]
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.core.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jst.pagedesigner/[1.1.0,2.0.0)
Unsatisfied dependency: [com.icesoft.eclipse.icefaces.v1.7.2.feature.feature.group 1.0.0.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/com.icesoft.eclipse.icefaces.v172/[1.0.0.200810101024,1.0.0.200810101024]
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.core.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jst.pagedesigner.jsp.core/[1.1.0,2.0.0)
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.core.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jst.pagedesigner/[1.1.0,2.0.0)
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.core.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/com.icesoft.ide.eclipse.icefaces.core/[3.4.1.200810101024,3.4.1.200810101024]
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.core.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/com.icesoft.ide.eclipse.icefaces.doc/[1.7.1.200810101024,1.7.1.200810101024]
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.core.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/com.icesoft.ide.eclipse.designtime/[1.7.2.200810101024,1.7.2.200810101024]
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.core.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jst.pagedesigner.jsf.ui/[1.1.0,2.0.0)
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.facelets.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/com.icesoft.ide.eclipse.icefaces.core/3.4.0
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.facelets.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/com.icesoft.ide.eclipse.icefaces.facelets/[3.4.1.200810101024,3.4.1.200810101024]
Unsatisfied dependency: [com.icesoft.ide.eclipse.icefaces.facelets.feature.feature.group 3.4.1.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jst.jsf.facelet.core/0.1.0

--- ICEFACES v1.7.2. RUNTIME LIBRARY only ---
Cannot complete the request. See the details.
Unsatisfied dependency: [com.icesoft.eclipse.icefaces.v1.7.2.feature.feature.group 1.0.0.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/com.icesoft.eclipse.icefaces.v172/[1.0.0.200810101024,1.0.0.200810101024]
Unsatisfied dependency: [com.icesoft.eclipse.icefaces.v1.7.2.feature.feature.group 1.0.0.200810101024] requiredCapability: org.eclipse.equinox.p2.iu/com.icesoft.eclipse.icefaces.v172/[1.0.0.200810101024,1.0.0.200810101024]


Peter
ken.fyten

Joined: 26/Oct/2004 00:00:00
Messages: 1346
Offline


Peter,

I believe some people have had some success using the standard Eclipse integration with RAD 7.5. Please create a new thread for this topic and someone from our tools group will respond.

Thx.
Ken

Ken Fyten
VP Product Development
ICEsoft Technologies, Inc.
 
Forum Index -> Tools
Go to:   
Powered by JForum 2.1.7ice © JForum Team