voyent
Software stack for using Icefaces 3.3  XML
Forum Index -> General Help
Author Message
jeff_prideaux

Joined: 07/Sep/2011 18:59:17
Messages: 15
Offline


We have an icefaces project currently using icefaces 1.8 (tomcat 6, myEclipse 9, java 7) that we would like to upgrade to more recent software components without yet taking the step to migrate all the ice tags over to ace tags - thus interested in icefaces 3.3 (the last version that still supports the old ice-tags).

We would also like to use Netbeans as the IDE for going forward.

Can anyone suggest the appropriate version of the following so that everything "goes together" to get the highest versions that still work together.

Netbeans
Tomcat
Java

We have tried Netbeans 12.6 with java17 and tomcat10 but it only seems to support a JSF framework of versions 2.3 and 1.2 and then icefaces does not show-up in the components tab of the JSF set-up. I'm hoping that a lower version of Netbeans may allow for easier set-up but don't know which would be the highest supported version.

P.S. we are working in linux.
jeff_prideaux

Joined: 07/Sep/2011 18:59:17
Messages: 15
Offline


I did learn that I can user Netbeans version 12.6 along with GlassFish AppServer 4.1.2 where GlassFish is using java8 and get Icefaces to show up during the JSF framework set-up although only icefaces 3.1 was added in and not all the way. I then was able to manually edit the POM file to get all the 3.3 versions of icefaces and also add in the JSF dependency for JSF version 2.1.19. Then after reloading POM file and rebuilding from dependencies, the Welcome_to_icefavces page works. I did also have JDK11 installed so I don;t jknow if that was necessary for Netbeans12.6 to run.

My only remaining question is what is the latest version of Tomcat that can be used with icefaces 3.3. I could not get tomcat10 to work.
 
Forum Index -> General Help
Go to:   
Powered by JForum 2.1.7ice © JForum Team