voyent
ICEfaces 1.0.1 to 1.5 issue with Eclipse project conversion  XML
Forum Index -> Tools
Author Message
hptb

Joined: 18/Aug/2006 00:00:00
Messages: 18
Offline


Hi,

I have been reading the release notes and other included documentation for ICEfaces 1.5 but cannot find the answer to my problem.

Specifically, we have an Eclipse 3.2 (with WTP 1.5) project that uses the ICEfaces 1.0.1 project facet. After upgrading to the new 1.5, I cannot seem to uncheck the 1.0.1 facet so I can then check the 1.5 facet. I get an error saying "icesoft.icefaces 1.0.1 cannot be uninstalled."

If I check 1.5 (while 1.0.1 is checked), I get a null pointer exception when I finish the task.

Do I have to destroy the project and start over with a new Eclipse project, or is there an upgrade path from 1.0.1 to 1.5 in Eclipse?

Thank you for your time,
Todd
liming.wu

Joined: 26/Oct/2004 00:00:00
Messages: 441
Offline


You need to remove ICEfaces eclipse integration 1.0.1 by removing diretcories com.icesoft.tools.eclipse_1.0.1 and com.icesoft.ide.eclipse.facet_1.0.1 from ECLIPSE_HOME/plugins/.

In 1.5.0, project conversion can be done by adding ICEfaces facet. Check readme.html for detail.

Note: there are 2 eclipse integration 1.5.0. One is for eclipse 3.2.x with WTP 1.5.x but without JSF tools. Another is for eclipse v3.2.x with WTP and JSF tools 1.5.x.

[Email]
hptb

Joined: 18/Aug/2006 00:00:00
Messages: 18
Offline


Hi,

Thank you for your response. I appreciate it.

I did exactly what you suggested (even the first time I tried the conversion). Adding the ICEfaces 1.5 facet to the project fails.

The error indicates simply that it failed. The detailed error indicates a ConcurrentModificationException occurred.

Do you have any other suggestions or will I just have to recreate the project from scratch? I even tried deleting my Eclipse installation and rebuilding it. That seems to work fine until I try to add the ICEfaces facet to the project where it fails with the exception.

Thanks,
Todd
hptb

Joined: 18/Aug/2006 00:00:00
Messages: 18
Offline


Also, if I try to use the WTP with JSF, I get a different exception. The exception is a NullPointerException.

If I select "Next" instead of "Finish" while adding the facet, the next page displays an error: ICEfaces Libraries v1.5.0 MUST be selected and marked as "Deploed" (that is copied exactly as shown from the dialog box)

When using WTP without JSF, the error is not there, but the ConcurrentModificationException results.

Thanks,
Todd
philip.breau


Joined: 08/May/2006 00:00:00
Messages: 2989
Offline


Hi Todd,

We need to clarify exactly what your Eclipse platform is. Can you find out exactly what version of WTP you have (I know you said 1.5) and if you have any other plugins, such as the JSF module.

Do you remember which Eclipse plugin you installed from ICEfaces 1.0.1? And which Eclipse plugin are you trying to install now?

Also, if you could provide the Eclipse log that would be helpful. It's usually found under <user-dir>\workspace\.metadata\.log

Thanks,
Philip

.
hptb

Joined: 18/Aug/2006 00:00:00
Messages: 18
Offline


Hi,

Thank you again for such excellent and fast support.

I removed my Eclipse environment completely again and reinstalled everything using WTP without JSF. Now I can add the ICEfaces 1.5 facet.

My environment for scenario 1 is:

- Eclipse 3.2
- Eclipse WTP: wtp-all-in-one-sdk-R-1.5.0-200606281455-win32.zip
- Eclipse WTP-JSF: wtp-jsf-R-1.5.0-200606281455.zip
- ICEfaces 1.5: ICEfaces-v1.5.0-Eclipse-JSF.zip

My environment for scenario 2 is: (this is the one I am using now)

- Eclipse 3.2
- Eclipse WTP: wtp-all-in-one-sdk-R-1.5.0-200606281455-win32.zip
- ICEfaces 1.5: ICEfaces-v1.5.0-Eclipse.zip

In both cases, I am using JFreeChart & ChartCreator. The issue existed with/without these installed.

Now that it works, I am off troubleshooting why my project won't run with ICEfaces 1.5. I get:

ERROR [[/myproject] Error configuring application listener of class com.sun.faces.config.ConfigureListener

That is another issue, though. :)

Thanks,
Todd
liming.wu

Joined: 26/Oct/2004 00:00:00
Messages: 441
Offline


As for the error ICEfaces Libraries v1.5.0 MUST be selected and marked as "Deploed" , it indicates you are using the integration designed for Eclipse+WTP+JSF and you must have Eclipse WTP and JSF installed. The error ICEfaces Libraries v1.5.0 MUST be selected and marked as "Deploed" indicates ICEfaces Libraries v1.5.0 is not selected and added in JSF Capabilities dialog and you need to click back button and select/add ICEfaces Libraries v1.5.0 and then error will go away.

Newly released Eclipse 3.2 1+ wtp 1.5.2 fixes some issues related to tag awareness and ICEfaces Eclipse Integration works with the latest version.

Liming
[Email]
hptb

Joined: 18/Aug/2006 00:00:00
Messages: 18
Offline


I do understand that. As per my previous post, that is exactly what we did, and still had the issue.

We finally got the project to convert by uninstalling/rebooting the OS/installing (shouldn't be necessary, but must have freed a locked resource), but now the project will not deploy any ICE jar files at all. In fact, there are no jar files as part of the deployed project. ICE 5.0 is part of the project facets (we are not using the JSF portion, as we get exceptions going that route).

I think it may be easier to stop trying to get this process working, and create a new project and start from scratch with our files.

Maybe for a future version, your readme.html file can include instructions for upgrading versions of ICE projects (rather than converting a non-ICE project to an ICE project).

Thank you for your help,
Todd
hptb

Joined: 18/Aug/2006 00:00:00
Messages: 18
Offline


An update...

We noticed the faces-config.xml file was missing the namespace as in:

<faces-config xmlns="http://java.sun.com/JSF/Configuration">

Our 1.0.1 (automatically built) had:

<faces-config>

The upgrade didn't change that. Now, our project compiles normally, but it still will not export ANY jar files.

Regards,
Todd
liming.wu

Joined: 26/Oct/2004 00:00:00
Messages: 441
Offline


"We noticed the faces-config.xml file was missing the namespace"

Looks like you are using ICEfaces Eclipse JSF tools (part of WTP) integration bundle. This integration bundle is based on Eclipse WTP and JSF tools. Actually faces-config.xml is created by Eclipse JSF tools. faces-config.xml template created by the ICEfaces Eclipse WTP integration bundle does includes the namespace.

"it still will not export ANY jar files"
Export your project to a war file should include all included dependent jar files.

[Email]
hptb

Joined: 18/Aug/2006 00:00:00
Messages: 18
Offline


Hi,

Thank you for your response. I appreciate it.

Actually, we are not using the JSF portion. I understand your comment, but we have reinstalled Eclipse on various developer machines to ensure we are not using the WTP with JSF.

If it helps, I am attaching a JPG image of our facets. Please notice no JSF at all in the selection. WTP JSF is not installed.

We built a new project and it works perfectly. It would be better to upgrade ICE 1.0.1 to 1.5, but starting with a new project and copying the older files over works well.

Again, thanks,
Todd
[Thumb - ProjectFacets.jpg]
 Filename ProjectFacets.jpg [Disk] Download
 Description
 Filesize 67 Kbytes
 Downloaded:  506 time(s)

 
Forum Index -> Tools
Go to:   
Powered by JForum 2.1.7ice © JForum Team