voyent
Problems migrating from previous version (JSC2)  XML
Forum Index -> Tools
Author Message
burferd

Joined: 04/May/2006 00:00:00
Messages: 381
Offline



I have gone through the process of installing and uninstalling the new version a couple times and I still get the problem that a project I had running under CE1.01 is looking for the old libraries.

When I try to 'Resolve References' the unresolved references point to:
Project_Design-time_ICEfaces_Component_Suite(EA2),
ICEfaces Design-Time1.0.1 Early Access,
ICEfaces Run-Time Support,
WebApplication_Design-Time_ICEfaces_Component_Suite(EA2),
WebApplication_Runtime_ICEfaces_Component_Suite(EA2),
Project_Runtime_ICEfaces_Component_Suite(EA2)

I removed the complib directory from the project.
I removed the 2_1 directory

The only thing that I can think of that I might not have done correctly is
to remove the cache files. But someone told me they were in the var directory under 2_1 which was deleted.

Any idea how to get rid of these unresolved references?

I even tried the "ICEfaces Integration.." option under the 'files' panel.

Any suggestions on what to do next???
frank.ye

Joined: 26/Oct/2004 00:00:00
Messages: 709
Offline


The library definition within netbeans based IDE is under following directory:

For example: windows:
C:\Documents and Settings\fye\.Creator\2_1\config\org-netbeans-api-project-libraries\Libraries

If you want clear old libraries definition, you need to do it manually.

Based on the current JSC 2 update 1 release library structure,

for each project, the only depends on the following:

WebApplication6\lib\complibs

So the following should be a clean project to start with:

removed the complib directory from the project.
removed the 2_1 directory
removed the libraries need to "Resovle References"

Then use "ICEfaces Integration.." or drag and drop one component to the page.



[Email]
burferd

Joined: 04/May/2006 00:00:00
Messages: 381
Offline


Thanks, that makes sense.
 
Forum Index -> Tools
Go to:   
Powered by JForum 2.1.7ice © JForum Team