voyent
Messages posted by: rajkumar  XML
Profile for rajkumar -> Messages posted by rajkumar [8]
Author Message
Hi Adnan,

Thank you for your prompt reply, that helped and I am able to navigate to a certain page, when I insert a new record.

----

I have a another doubt/possibly a bug ...am not sure working on this right now. Could you please help ...

Let me say, I have a page "A.jsp", which has a dataTable referred by XX bean and I have a paginator which refer's XX bean for the paginator properties such as vertical,maxpages and so on ...

Now, a little further down on the same "A.jsp" page I have another JSP:include(B.jsp) which has another dataTable and dataPaginator embedded in it, now in B.jsp the dataTable and paginator also refer XX bean,
the problem - for some reason the paginator does not get rendered.

In other words , it simply is a nested page , which refers the same bean for the dataTable and paginator properties. The list that both of them operate on are different.
The included page reflects the rowCount property from XX.rowCount but does not render the paginator.
I've tried so far using a subview.. still the paginator does not appear ... I gues it has something to do with the same bean being used ... but really re-factoring the bean is a lot of work ...

I hope the details are sufficient here ... Any help is greatly appreciated.
Hi Philip, I have a problem with the paginator ... its quite urgent ... could you please have a look at this thread ...

http://support.icesoft.com/jive/thread.jspa?threadID=2222&tstart=0
Hi Adnan, thanks for your prompt reply.

For example ...

<f:subview >
<jsp:directive.include file="./includes/A.jsp" />
</f:subview>

and if A includes B.jsp

Now both in A and B if I have similar data tables and dataPaginators, then paginator does not render in B ...

A's dataTable works on XYZ list.
B's dataTable works on another different List.

the include works fine, but the paginator is just blank in the second include. Both A and B are using the same bean for accessing the list and setting the properties of the paginator.

Thanks

some templating, cant post source here ... sorry about that.

a.jsp

<ice:dataTable id="a1" value="mybean.list">

</ice:datatable>

<ice:paginator for="a1">
</ice:paginator>

---- a.jsp works fine ----
now a.includes b
---------

<f:subview id="someuniquestring">
<jsp:directive.include file="b.jsp" />
</f:subview>

---- In b.jsp ---

<ice:dataTable id="a2" value="mybean.differentlist">

</ice:datatable>

<ice:paginator for="a2">
</ice:paginator>

---- now in b.jsp --- the data table renders, but the paginator is not visible...

pls let me know if this is okay ...

I posted wrongly earlier that I am not able to see it using the dom inspector ... I can see the id using dom inspector.. but it is not visible...


Message was edited by: rajkumar
Hey shisir , did u find a solution to your problem ? I have a similar issue ...

would you be kind enough to post some directions here ...

Thanks
Raj
Hello,

Regarding PanelTab , Modal Dialog Boxes and TabChangeListener I have a problem.

The Modal Dialog Box does not seem to display when I switch tabs should we have individual Modal dialog boxes for every panelTab tag?

The tabChangeListener event gets fired. And Initially the Modal Dialog gets Displayed, if i set the visibility in the constructor of the backing bean default true, subsequently it does not get displayed when I switch between tabs although the event gets fired. any help is greatly appreciated.

Thnx
Raj,
Hi Adnan,

Thank you very much it worked.

regards
raj
Hi,

I cannot get commandLink to work. This is what I have tried.

my jsp pages are in a sub directory inside WEB-INF pages, and when I try to link from page to another it simply refreshes the page.

The backing bean gets invoked but the page does not get forwarded, the redirects fail with a 404 error not found, when configured from faces-config.xml, what should i check any pointers please?

thanks in advance,
Some More Details, clicked post accidentally ...

I have a jsp page under the webapp directory from that root level I want to link to a page under the WEB-INF directory.

a) When using the actionListener the method gets invoked but using "FacesContext.getCurrentInstance().getExternalContext().dispatch("/WEB-INF/...");"
throws a null pointer exception at bridgestate ... some
java.lang.NullPointerException
at com.comp.ClassName(ClassName:<LineNumber>)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at org.apache.myfaces.el.MethodBindingImpl.invoke(MethodBindingImpl.java:129)
at javax.faces.component.UICommand.broadcast(UICommand.java:86)stack trace below

That basically returns the requestdispatcher as null I guess.

2) if I attempt to use the action attribute there are no errors on the out log, but trying to use redirect fails with a 404...

Any help is greatly appreciated.

Thank You,

raj,
 
Profile for rajkumar -> Messages posted by rajkumar [8]
Go to:   
Powered by JForum 2.1.7ice © JForum Team